JanaServer - Forum
Registrierung Kalender Mitgliederliste Teammitglieder Suche Häufig gestellte Fragen Zum Chat Zum Portal Zur Startseite

JanaServer - Forum » Jana 2 - Konfiguration » Servertypen » Http Server » Php Funktioniert teilweise nicht » Hallo Gast [Anmelden|Registrieren]
Letzter Beitrag | Erster ungelesener Beitrag Druckvorschau | Thema zu Favoriten hinzufügen
Neues Thema erstellen Antwort erstellen
Zum Ende der Seite springen Php Funktioniert teilweise nicht
Autor
Beitrag « Vorheriges Thema | Nächstes Thema »

it-group it-group ist männlich
Jungspund


Dabei seit: 26.02.2012

Fragezeichen Php Funktioniert teilweise nicht Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Ich habe auf meinen Rechner PHP u. Jana installiert und danach habe ich bei Jana in den Grundeinstellungen auf die IP 192.168.1.10 alles aktivert (proxy, http, administration...) und gespeichert. Danach bin ich auf Servertypen -> http-Server und habe bei ISAPI-Module die php5.dll eingebaut. (ach ja php ist bei mir auf C:\Programme\Php installiert). Danach habe ich denn Server neugestartet und habe die php.ini verändert ( ich habe die php.ini nach anleitung von janasupport verändert, ich glaube es wahr thomas mit dem ich geschrieben habe). Und als ich dann später in formular mit php posten wollte ging das schief. der quelltext der html datei:
<form action="seite2.php" method="post">
<input type="text" name="text">
<input type="submit">
</form>
und in seite2.php steht:
<?php
echo $_POST["text"]
?>
und wenn ich jetzt mal in die textbox hallo eingebe und dann auf Absenden drücke erscheint in der php datei gar nichts. nicht einmal im quelltext steht etwas, thonà hauck konnte auch nicht helfen. Bitte helft mir.

Dieser Beitrag wurde 1 mal editiert, zum letzten Mal von it-group: 26.02.2012 13:57.

26.02.2012 11:03 it-group ist offline E-Mail an it-group senden Homepage von it-group Beiträge von it-group suchen Nehmen Sie it-group in Ihre Freundesliste auf

IceMan IceMan ist männlich
Haudegen


Dabei seit: 01.11.2001
JanaServer: 2.6.0.225

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Hi it-group,

also soweit ich weiß kann PHP ab Version 5 nicht mehr als ISAPI in Jana eingebunden werden,nur noch als fast-CGI!!

die php5.dll ist hier auch nicht geeignet, wenn dann müsste die Datei php5isapi.dll heißen, die es aber leider nicht mehr gibt.

Binde statt dessen die php-cgi.exe in Jana ein.


Gruß

__________________
www.mein-trainingsportal.de

- Lauf- & Radsport Dokumentation und Auswertung
- Startseite
27.02.2012 00:23 IceMan ist offline E-Mail an IceMan senden Homepage von IceMan Beiträge von IceMan suchen Nehmen Sie IceMan in Ihre Freundesliste auf

it-group it-group ist männlich
Jungspund


Dabei seit: 26.02.2012

Themenstarter Thema begonnen von it-group
Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

hm?

Bei mir sind zwei DLL´s
einmal php5.dll und php5isapi.dll
!
Oder soll ich einfach nur php-cgi.exe statt php.exe verwenden.
Brauche nochmal hilfe!
28.02.2012 12:25 it-group ist offline E-Mail an it-group senden Homepage von it-group Beiträge von it-group suchen Nehmen Sie it-group in Ihre Freundesliste auf

IceMan IceMan ist männlich
Haudegen


Dabei seit: 01.11.2001
JanaServer: 2.6.0.225

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Hi,

Du bist Dir sicher, dass du die php5isapi.dll und nicht die php5nsapi.dll im Verzeichnis hast?!

Ich hab mir mal die aktuelle PHP-Version 5.3.10 runtergeladen, da gibt es nur die php5nsapi.dll, die kann hier nicht verwendet werden.

Ich habe PHP als CGI eingebunden sprich die php-cgi.exe. Ob die php.exe überhaupt in Verbindung mit Jana funktioniert kann ich nicht sagen, da ich dies noch nie probiert hab.

Das Thema wurde auch im Forum schon mal besprochen:
PHP 5.3.x Konfiguration

Hoffe ich konnte helfen.

__________________
www.mein-trainingsportal.de

- Lauf- & Radsport Dokumentation und Auswertung
- Startseite
28.02.2012 22:39 IceMan ist offline E-Mail an IceMan senden Homepage von IceMan Beiträge von IceMan suchen Nehmen Sie IceMan in Ihre Freundesliste auf

djmugge djmugge ist männlich
Lebende Foren Legende


images/avatars/avatar-730.jpg

Dabei seit: 16.06.2002
JanaServer: Mod-Version

Auf diesen Beitrag antworten Zitatantwort auf diesen Beitrag erstellen Diesen Beitrag editieren/löschen Diesen Beitrag einem Moderator melden       Zum Anfang der Seite springen

Schau dir mal dieses Posting. Hatte dieses Problem auch.

__________________
Jana in der aktuellen Version
Win XP SP3
Virtual Box XP Prof. SP3
28.02.2012 22:44 djmugge ist offline E-Mail an djmugge senden Homepage von djmugge Beiträge von djmugge suchen Nehmen Sie djmugge in Ihre Freundesliste auf Fügen Sie djmugge in Ihre Kontaktliste ein MSN Passport-Profil von djmugge anzeigen
Baumstruktur | Brettstruktur
Neues Thema erstellen Antwort erstellen
JanaServer - Forum » Jana 2 - Konfiguration » Servertypen » Http Server » Php Funktioniert teilweise nicht

Impressum | Sponsoring | Datenschutzerklärung | Haftungsausschluß

Forensoftware: Burning Board, entwickelt von WoltLab GmbH